Hose into electrics is not a good idea. Problems with datatool alarm

Hose into electrics is not a good idea. Problems with datatool alarm

After the clean the bike is seen here, 44,400 miles so far and a oil leak started so I cleaned the bike with a degreaser. Took the seat up and cleaned under the seat. Big mistake as after the bike would not start. The alarm started to make some unusual chirp noises and would not restart the bike. I found a broken wire to the alarm supply. Cleaned this and waited for the alarm to dry a bit.
One thing to pass on is try not to use too much water. the bike is not made for this under the seat. Its a mistake that I should not have made. Now the bike is clean. I found a oil seal loose at the back of the clutch with help from Harry and Dave. The seal pushed back in. The second leak was that the oil filter was slightly loose. I tightened this and all seems ok now. Fingers crossed there should be no problems for my three thousand mile round trip to Mugello for moto gp 2013. To visit Lake Garda and the surrounding countryside.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s